Visual tour

This section gives an overview of the various features of Desktop.

visual tour2

1. Projects

A Project in Desktop is a representation of a development folder on disk. You can create local DBMS’s, connect to remote DBMS’s and add files within your project. Neo4j Desktop allows you to manage multiple Projects and it is easy to move both DBMS’s and files between different Projects by drag and drop. However, you can have only one active DBMS or remote connection at a time.

2. DBMS

A DBMS, database management system, is a Neo4j server instance which contains a minimum of the system database and a default database. Upon creation of a DBMS, the default database is called neo4j, but you can rename it or create a new database as the default.

Neo4j Desktop includes a free Developers License of Neo4j Enterprise Edition which gives the user local access to Enterprise Edition features, such as multiple databases. A DBMS in Desktop can thus contain a number of databases in addition to the system and default databases. Please see the Operations Manual → Manage databases for more information on multiple databases.

When you create a new DBMS in a Project, this will be with the default version of Neo4j. However, you are able to select a different version of Neo4j. Keep in mind that this often requires the resources for this to be downloaded and thus requires an internet connection.

A plugin is additional functionality that can be enabled for a DBMS. With the latest version of Neo4j Desktop, the following plugins are available for installation for your local DBMS:

  • APOC - A library of user-defined procedures and functions to help with many different tasks in areas like data integration, graph algorithms or data conversion.

  • GDS Library - Common graph algorithms for Neo4j.

  • GraphQL - A GraphQL-endpoint extension that translates GraphQL queries into Cypher statements.

  • Neo4j Streams - An integration between Neo4j and Kafka in order to ingest data into your graph or to send update events to the event log.

  • neosemantics (n10s) - A plugin that enables the use of RDF and associated vocabularies in Neo4j.

Neo4j Desktop lets you view and modify the settings for your DBMS directly. By selecting Settings from the More Options-menu, an editable neo4j.conf opens in a new window. However, for most settings, a modification requires the DBMS to be restarted for the change to take effect. Please see Operations Manual → The neo4j.conf file for more information on the contents of the neo4j.conf.

Similarly, the main log file, neo4j.log, can also be viewed directly from Desktop, from the Logs in the More Options-menu. This opens a separate window displaying the neo4j.log-file. You can also access other logs from Open folderLogs.

2.1. Memory configuration

Desktop sets the following memory configuration for each created DBMS, by default:

dbms.memory.heap.initial_size=512m
dbms.memory.heap.max_size=1G
dbms.memory.pagecache.size=512m

If you need a different memory configuration for your setup, you can edit the neo4j.conf file of each DBMS to suit your needs. As mentioned above, the neo4j.conf file can be accessed from the Settings option in the More Options-menu.

Keep in mind that the DBMS should be restarted after any changes to the neo4j.conf file for the changes to take effect.

For more information on memory configuration, please see Operations Manual → Memory configuration.

3. Remote connection

Apart from managing local DBMS’s, Neo4j Desktop also allows you to connect to a remote instance. This can be an instance running on GCE, Aura, or hosted on a local network, for example. The remote connection uses the bolt protocol.

Remote connections are accessible for each Project, in the Add-dropdown menu. See Connect to a remote DBMS to learn more about how to connect to a remote instance.

4. Graph applications

There are several ways to interact with the graph. One way is using a Graph app and Desktop comes bundled with two such apps, Neo4j Browser and Bloom. Please see the Browser documentation and the Bloom documentation for more information. Neo4j Browser and Bloom are used to visualize and query the graph, but other apps offer import tools for relational databases, monitoring tools and query log analyzers, for example. You can select and install these from a curated list in the Graph App Gallery in Desktop.

graph apps drawer

Additionally, it is also possible to install other graph apps with the Install option. You can either drag and drop a Graph App archive in the box or enter a URL to install.

The installed Graph Apps can then be launched from the sidebar, from the Open menu, or from the Action bar.

5. Files

Apart from adding DBMSs, Desktop also lets you add files and folders to your Project. These can be Cypher files and Neo4j Browser guides which will both open in Neo4j Browser when you click them. In addition, you can also add database dump files to this section. The dump files can be used to restore a DBMS and thus add it to your Project.

To add files, you can use the Add dropdown menu in your Project or you can drag and drop the files into the File section. If you place files in the Project folder, e.g. with your file manager or from the command line, Desktop will pick them up and display them in this section. The dropdown menu lets you filter your added files and folders by name, size, date of creation, date of last modification, or date it was last opened.

files

You can move your files easily between Projects by dragging a file from this section and dropping it in a different Project in the Project menu on the sidebar.