Supported Neo4j versions

Here you can find the compatibility matrix between the GDS library and Neo4j.

In general, the latest version of GDS supports the latest version of Neo4j and vice versa. This is the recommended combination.
If your version of GDS or Neo4j is not listed in the matrix, you should upgrade.

Neo4j version Neo4j Graph Data Science

5.16

2.7, 2.6, 2.5.7 [1]

5.15

2.6, 2.5.6 [1] or later

5.14

2.6, 2.5.5 [1] or later

5.13

2.6, 2.5.1 [1] or later

5.12

2.6, 2.5 [1]

5.11

2.6, 2.5 [1]

5.10

2.5 [1]

5.9

2.5 [1]

5.8

2.5 [1]

5.7

2.5 [1]

5.6

2.5 [1]

4.4.27 or later

2.6, 2.5.3 [1] or later

4.4.9 - 4.4.26

2.6, 2.5 [1]

1. 2.5 version series is end-of-life and will not receive further patches. Please use a later version.